Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos de Schneider Electric

Múltiples vulnerabilidades en productos de Schneider Electric

Fecha de publicación: 
11/01/2022
Importancia: 
4 - Alta
Recursos afectados: 
  • Modicon M340 CPUs: BMXP34* todas las versiones;
  • Modicon Quantum CPUs con integrated Ethernet (Copro): 140CPU65* todas las versiones;
  • Modicon Premium CPUs con integrated Ethernet (Copro): TSXP57* todas las versiones;
  • Modicon M340 ethernet modules todas las versiones:
    • BMXNOC0401;
    • BMXNOE01*;
    • BMXNOR0200H.
  • Modicon Quantum y Premium factory cast communication modules todas las versiones:
    • 140NOE77111;
    • 140NOC78*00;
    • TSXETY5103;
    • TSXETY4103.
  • Modicon M340 CPUs: BMXP34* todas las versiones;
  • Modicon Quantum CPUs con integrated Ethernet (Copro) todas las versiones:
    • 140CPU65*;
    • TSXP57*.
  • Modicon M340 ethernet modules: BMXNOC0401 BMXNOE01* BMXNOR0200H todas las versiones;
  • Modicon Quantum y Premium factory cast communication modules todas las versiones:
    • 140NOE77111;
    • 140NOC78*00;
    • TSXETY5103;
    • TSXETY4103.
  • Easergy T300 conectados a 3G/4G con módem:
    • Easergy HU250 3G modem box - Five Bands UMTS/HSPA+;
    • Easergy HU250 4G modem box con GPS clock synchronization.
  • Easergy P5 todas las versiones de firmware anteriores a V01.401.101;
  • Easergy P3 todas las versiones anteriores a V30.205;
  • ConneXium Tofino:
    • Firewall – número de pieza TCSEFEA23F3F22 versiones anteriores a v03.23;
    • OPC-LSM – número de pieza TCSEFM0000 versiones anteriores a Firewall host versión v03.23;
    • Firewall – número de pieza TCSEFEA23F3F20/21 todas las versiones;
    • Firewall – número de pieza TCSEFEA23F3F22;
    • OPC-LSM – número de pieza TCSEFM0000;
    • Firewall – número de pieza TCSEFEA23F3F20/21.
  • M241/M251 todas las versiones;
  • EcoStruxure Machine Expert todas las versiones;
  • Harmony/ Magelis Vijeo Designer V6.2 SP11 Hotfix 3 y anteriores:
    • HMISTU Series;
    • HMIGTO Series;
    • HMIGTU Series;
    • HMIGTUX Series;
    • HMIGK Series;
    • HMISCU Series.
  • Eurotherm:
    • E+PLC100 todas las versiones;
    • E+PLC400 todas las versiones;
    • E+PLC tools todas las versiones.
  • EcoStruxure Power Monitoring:
    • Expert;
    • Expert 2020;
    • Expert 9.0 y anteriores.
Descripción: 

Schneider ha publicado 16 vulnerabilidades, siendo 8 de severidad alta, y 8 medias.

Solución: 

Aplicar las medidas de mitigación descritas en mitigations en la sección de Referencias de cada uno de los productos.

Detalle: 

Las vulnerabilidades de severidad alta son del tipo:

  • Existe una vulnerabilidad de copia de búfer sin comprobar el tamaño de la entrada que podría permitir a un atacante provocar el bloqueo del programa y la ejecución de código arbitrario mediante el envío de paquetes especialmente diseñados al dispositivo a través de la red. Se han asignado los identificadores CVE-2022-22725 y CVE-2022-22723 para esta vulnerabilidad.
  • Un atacante puede acceder a un dispositivo Tofino que no haya sido puesto en marcha utilizando credenciales predeterminadas codificadas a través de SSH. Se ha asignado el identificador CVE-2022-30064 para esta vulnerabilidad.
  • El consumo incontrolado de recursos podría permitir a un atacante la denegación de servicio en los puertos 80 (HTTP) y 502 (Modbus), al enviar un gran número de paquetes TCP RST o FIN a cualquier puerto TCP abierto del PLC. Se ha asignado el identificador CVE-2022-22724 para esta vulnerabilidad.
  • El uso de credenciales embebidas podría permitir a un atacante que obtuviera la clave criptográfica SSH del dispositivo y tomara control activo de la red operativa local conectada al producto, además de observar y manipular el tráfico asociado a la configuración del producto. Se ha asignado el identificador CVE-2022-22722 para esta vulnerabilidad.
  • Un atacante puede eludir Modbus enforcer utilizando paquetes Modbus especialmente diseñados. Se ha asignado el identificador CVE-2022-30065 para esta vulnerabilidad.
  • Existe una vulnerabilidad de denegación de servicio en la herramienta lmadmin de FlexNet Publisher, al realizar una solicitud POST falsa en lmadmin, utilizando la herramienta basada en la web que se despliega con PME. Se ha asignado el identificador CVE-2022-8963 para esta vulnerabilidad.
  • La validación de entrada inadecuada podría permitir a un atacante no autenticado ver datos, cambiar la configuración, afectar a la disponibilidad del software, o afectar a una la máquina local de un usuario cuando éste hace clic en un enlace especialmente diseñado. Se ha asignado el identificador CVE-2022-22727 para esta vulnerabilidad.

Para las vulnerabilidades de severidad media se han asignado los identificadores: CVE-2020-7534, CVE-2020-8597, CVE-2021-30063, CVE-2021-30066, CVE-2022-22804, CVE-2021-30061, CVE-2021-30062 y CVE-2022-22726.

Encuesta valoración