Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos Phoenix Contact

Múltiples vulnerabilidades en productos Phoenix Contact

Fecha de publicación: 
08/11/2022
Identificador: 
INCIBE-2022-1003
Importancia: 
4 - Alta
Recursos afectados: 

Versiones desde 1.0 hasta 1.89 de los productos:

  • Config+,
  • PC Worx,
  • PC Worx Express.
Descripción: 

El investigador Michael Heinzl ha descubierto estas vulnerabilidades, que han sido publicadas por el investigador en coordinación entre el fabricante y el CERT@VDE. La explotación de estas vulnerabilidades, de severidad alta, podría provocar un desbordamiento de búfer de la pila, la liberación de memoria no asignada o un acceso de lectura no autorizado debido a la insuficiente validación de los datos de entrada.

Solución: 

Actualizar Automation Worx Software Suite a una versión superior a 1.89.

Detalle: 
  • La manipulación de archivos PC Worx o Config+ podría provocar un desbordamiento de búfer de la pila y una omisión del acceso de lectura. Se ha asignado el identificador CVE-2022-3461 para esta vulnerabilidad.
  • La memoria podría leerse más allá del límite del búfer debido a la insuficiente validación de los datos de entrada. Se ha asignado el identificador CVE-2022-3737 para esta vulnerabilidad.

La disponibilidad, la integridad o la confidencialidad de una workstation de programación de aplicaciones podrían verse comprometidas por ataques que exploten estas vulnerabilidades.

Encuesta valoración