Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos CODESYS de 3S-Smart Software Solutions GmbH

Múltiples vulnerabilidades en productos CODESYS de 3S-Smart Software Solutions GmbH

Fecha de publicación: 
13/09/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • Todas las variantes de los siguientes productos CODESYS V3, en todas las versiones anteriores a la 3.5.14.10 que contengan el servidor web (CmpWebServer):
    • CODESYS Control para BeagleBone;
    • CODESYS Control para emPC-A/iMX6;
    • CODESYS Control para IOT2000;
    • CODESYS Control para Linux;
    • CODESYS Control para PFC100;
    • CODESYS Control para PFC200;
    • CODESYS Control para Raspberry Pi;
    • CODESYS Control RTE V3;
    • CODESYS Control RTE V3 (para Beckhoff CX);
    • CODESYS Control Win V3 (también parte de la configuración de CODESYS Development System);
    • CODESYS HMI V3;
    • CODESYS Control V3 Runtime System Toolkit;
    • CODESYS V3 Embedded Target Visu Toolkit;
    • CODESYS V3 Remote Target Visu Toolkit.
  • Todas las variantes de los siguientes productos CODESYS Control V3, en todas las versiones desde la 3.5.11.0 hasta la 3.5.15.0, que contengan el servidor OPC UA de CODESYS soportando OPC UA Security:
    • CODESYS Control para BeagleBone;
    • CODESYS Control para emPC-A/iMX6;
    • CODESYS Control para IOT2000;
    • CODESYS Control para Linux;
    • CODESYS Control para PFC100;
    • CODESYS Control para PFC200;
    • CODESYS Control para Raspberry Pi;
    • CODESYS Control RTE V3;
    • CODESYS Control RTE V3 (para Beckhoff CX);
    • CODESYS Control Win V3 (también parte de la configuración de CODESYS Development System);
    • CODESYS Control V3 Runtime System Toolkit.
  • CODESYS Development System V3, en sus arquitecturas de 32 y 64 bit, versiones anteriores a 3.5.15.0.
  • Servidores CODESYS V2.3 ENI, versiones anteriores a 3.2.2.24.
Descripción: 

Se han reportado múltiples vulnerabilidades en varios productos CODESYS de 3S-Smart Software Solutions GmbH. La explotación exitosa de estas vulnerabilidades permitiría a un atacante generar una condición de denegación de servicio, ejecutar código de manera remota, ejecutar o mostrar contenido malicioso de librerías manipuladas o acceder a archivos restringidos.

Solución: 

Se recomienda actualizar los equipos a las siguientes versiones de software para resolver estas vulnerabilidades:

  • 3.2.2.24;
  • 3.5.12.80;
  • 3.5.14.10;
  • 3.5.15.0.
Detalle: 
  • Una petición http o https, especialmente diseñada, permitiría a un atacante acceder a ficheros fuera del directorio de trabajo del controlador. Se ha reservado el identificador CVE-2019-13532 para esta vulnerabilidad.
  • Una petición http o https, especialmente diseñada, podría provocar un desbordamiento de búfer, lo que permitiría generar una condición de denegación de servicio o la ejecución de código de manera remota. Se ha reservado el identificador CVE-2019-13548 para esta vulnerabilidad.
  • El sistema expone contenido de la librería activa sin comprobar su validez, lo que permitiría ejecutar o mostrar contenido de librerías manipuladas. Se ha reservado el identificador CVE-2019-13538 para esta vulnerabilidad.
  • Una petición especialmente diseñada de un cliente OPC UA de confianza podría provocar una desreferencia de puntero NULL, pudiendo derivar en una condición de denegación de servicio. Se ha reservado el identificador CVE-2019-13542 para esta vulnerabilidad.
  • Una petición específicamente diseñada causaría un desbordamiento de búfer basado en una pila y, como consecuencia, se podría ejecutar código arbitrario en el servidor ENI o provocar una condición de denegación de servicio debido a un fallo en dicho servidor.

Encuesta valoración