Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos de CODESYS

Múltiples vulnerabilidades en productos de CODESYS

Fecha de publicación: 
19/12/2019
Importancia: 
3 - Media
Recursos afectados: 
  • CODESYS SP Realtime NT versiones anteriores a v2.3.7.28;
  • CODESYS Runtime Toolkit 32 bit full versiones anteriores a v2.4.7.54;
  • CODESYS PLCWinNT versiones anteriores a v2.4.7.54.
Descripción: 

Chen Jie, de NSFOCUS, ha reportado una vulnerabilidad de criticidad media que afectan a los dispositivos de CODESYS. Un atacante remoto podría generar una condición de denegación de servicio.

Solución: 

3S-Smart Software Solutions GmbH ha lanzado las siguientes versiones que solucionan dichas vulnerabilidades. Para obtener las actualizaciones hay que visitar el apartado de actualizaciones de la web de CODESYS:

  • CODESYS SP Realtime NT, actualizar a la versión v2.3.7.28
  • CODESYS Runtime Toolkit 32 bit full, actualizar a la versión v2.4.7.54
  • CODESYS PLCWinNT, actualizar a la versión v2.4.7.54
Detalle: 

Una petición, específicamente generada, enviada al servidor podría provocar una desreferencia del puntero NULL. Un atacante remoto podría generar una condición de denegación de servicio. Esta petición solamente es procesada en el controlador si no se ha configurado ninguna contraseña, o si previamente el atacante ha conseguido autenticarse. Se ha reservado el identificador CVE-2019-19789 para esta vulnerabilidad.

Encuesta valoración