Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos Carlo Gavazzi Controls

Múltiples vulnerabilidades en productos Carlo Gavazzi Controls

Fecha de publicación: 
27/09/2022
Identificador: 
INCIBE-2022-0937
Importancia: 
5 - Crítica
Recursos afectados: 
  • CPY Car Park Server, versiones anteriores a 2.8.3;
  • versiones anteriores a 8.5.0.3 de:
    • UWP 3.0 Monitoring Gateway y Controller;
    • UWP 3.0 Monitoring Gateway y Controller – versión EDP;
    • UWP 3.0 Monitoring Gateway y Controller – Security Enhanced.
Descripción: 

La investigadora, Vera Mens, de Claroty Research, coordinada y apoyada para esta publicación por el CERT@VDE, ha identificado 11 vulnerabilidades en distintos productos de Carlo Gavazzi Controls, siendo 6 de severidad crítica, 4 altas y 1 media.

Solución: 

Actualizar los productos afectados a las versiones correctoras:

  • CPY Car Park Server, versiones 2.8.3 o superiores;
  • versiones 8.5.0.3 o superiores de:
    • UWP 3.0 Monitoring Gateway y Controller;
    • UWP 3.0 Monitoring Gateway y Controller – versión EDP;
    • UWP 3.0 Monitoring Gateway y Controller – Security Enhanced.
Detalle: 

A continuación se detallan las vulnerabilidades críticas:

  • Un atacante remoto, no autenticado, podría hacer uso de las credenciales en texto claro para obtener acceso completo al dispositivo. Se ha asignado el identificador CVE-2022-22522 para esta vulnerabilidad.
  • Un atacante remoto, no autenticado, podría utilizar una vulnerabilidad de inyección SQL para obtener acceso completo a la base de datos, modificar usuarios y detener servicios. Se ha asignado el identificador CVE-2022-22524 para esta vulnerabilidad.
  • La falta de autenticación podría permitir el acceso completo a través de la API. Se ha asignado el identificador CVE-2022-22526 para esta vulnerabilidad.
  • Un atacante remoto, no autenticado, podría utilizar una validación de entrada inadecuada en un parámetro enviado por la API para ejecutar comandos arbitrarios del sistema operativo. Se ha asignado el identificador CVE-2022-28811 para esta vulnerabilidad.
  • Un atacante remoto, no autenticado, podría hacer uso de las credenciales en texto claro para obtener acceso de SuperUser al dispositivo. Se ha asignado el identificador CVE-2022-28812 para esta vulnerabilidad.
  • El dispositivo afectado es vulnerable a un path traversal que podría permitir a los atacantes remotos leer archivos arbitrarios y obtener el control total del dispositivo. Se ha asignado el identificador CVE-2022-28814 para esta vulnerabilidad.

Para el resto de vulnerabilidades se han asignado los identificadores: CVE-2022-28816, CVE-2022-22523, CVE-2022-28813, CVE-2022-22525 y CVE-2022-28815.

Encuesta valoración