Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos AVEVA Edge

Múltiples vulnerabilidades en productos AVEVA Edge

Fecha de publicación: 
23/11/2022
Identificador: 
INCIBE-2022-1023
Importancia: 
5 - Crítica
Recursos afectados: 

Las siguientes versiones de AVEVA Edge, un software HMI/SCADA, están afectadas: 

  •  2020 R2 SP1;  
  •  2020 R2 SP1 con HF 2020.2.00.40; 
  • AVEVA Edge 2020 R2 y todas las versiones anteriores (anteriormente conocido como InduSoft Web Studio) . 
Descripción: 

Se han detectado 4 vulnerabilidades de severidad crítica. Su explotación podría permitir a un atacante insertar archivos DLL maliciosos y engañar a la aplicación para que ejecute código.

Solución: 

AVEVA recomienda que las organizaciones evalúen el impacto de estas vulnerabilidades en función del entorno operativo, la arquitectura y las implementaciones de productos. 

  • Los usuarios de los prodctos afectados deben aplicar AVEVA Edge 2020 R2 SP2 lo antes posible. 
  • Restringir el acceso al puerto TCP/3997 
Detalle: 

Las vulnerabilidades detectadas podrían dar lugar a:

  • Que un atacante con acceso al sistema de archivos logre la ejecución de código arbitrario y la escalada de privilegios al engañar al paquete InstallShield de AVEVA Edge para que cargue una DLL no segura. Se ha asignado el identificador CVE-2016-2542 para esta vulnerabilidad.
  • El escaneo de la red interna y exposición de información confidencial del dispositivo. Se ha asignado el identificador CVE-2021-42794 para esta vulnerabilidad.
  • La ejecución de comandos arbitrarios no autenticados con el contexto de seguridad del proceso StADOSvr.exe. En la mayoría de los casos, será una cuenta de usuario con privilegios estándar con la que se inició el tiempo de ejecución de AVEVA Edge. Se ha asignado el identificador CVE-2021-42796 para esta vulnerabilidad.
  • Que un actor no autenticado engañe a AVEVA Edge runtime para que revele un token de acceso de Windows de la cuenta de usuario configurada para acceder a recursos de base de datos externos. Se ha asignado el identificador CVE-2021-42797 para esta vulnerabilidad.

Encuesta valoración