Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en productos de ABB

Múltiples vulnerabilidades en productos de ABB

Fecha de publicación: 
03/04/2020
Importancia: 
5 - Crítica
Recursos afectados: 
  • System 800xA Base, versión 6.1 y anteriores;
  • System 800xA Information Manager:
    • versión 5.1;
    • versión 6.0.0, hasta la 6.0.3.2;
    • versión 6.1.
  • TG/S 3.2 Telephone Gateway, Analogue, MDRC;
  • 6186/11 Telefon-Gateway, Analog (Busch-Jaeger brand);
  • OPC Server para AC800M, versión 6.0 y anteriores;
  • Control Builder MProfessional, versión 6.1 y anteriores;
  • MMSServer para AC800M, versión 6.1 y anteriores;
  • Base Software para SoftControl, versión 6.1 y anteriores;
Descripción: 

Los investigadores, William Knowles, de Applied Risk, y Maxim Rupp, han reportado 8 vulnerabilidades, dos de severidad crítica, tres altas y tres medias, que afectan a múltiples productos de ABB. Un atacante, con acceso remoto, podría provocar la detención del dispositivo, la ejecución de código de forma arbitraria, tomar el control del dispositivo y realizar una escalada de privilegios.

Solución: 
  • System 800xA Base, puede solucionarse mediante cualquiera de las siguientes acciones:
    • actualizar a la última versión 6.1 disponible;
    • actualizar a la versión 6.0.3 LTS, después de la 6.0.33.
  • TG/S 3.2 Telephone Gateway, Analogue, MDR y 6186/11 Telefon-Gateway, Analog (Busch-Jaeger brand):
    • Configurar los dispositivos, únicamente, en redes seguras.
  • Actualizar a la versión 6.0.3 LTS, después de la 6.0.3.3:
    • System 800xA Information Manager,
    • MMSServer para AC800M,
    • OPC Server para AC800M,
    • Control Builder MProfessional,
    • Base Software para SoftControl.
Detalle: 

A continuación se detallan las vulnerabilidades con severidades críticas y altas:

  • La configuración de control de acceso para el registro de Windows permite a los usuarios con pocos privilegios leer y modificar el contenido utilizado por las funciones del sistema. Un atacante autenticado podría causar el mal funcionamiento de diferentes sistemas. Se ha reservado el identificador CVE-2020-8474 para esta vulnerabilidad.
  • Un componente vulnerable en el servidor de mensajería instantánea (IM) podría permitir a un atacante ejecutar código arbitrario en el equipo de la víctima. Para explotar con éxito esta vulnerabilidad, es necesario persuadir al usuario para que acceda a un sitio web malicioso. Se ha reservado el identificador CVE-2020-8477 para esta vulnerabilidad.
  • Al acceder a una URL específica en el servidor web integrado del producto, un usuario malicioso podría acceder a diferentes puntos finales de la aplicación sin autenticarse, evadiendo las normas de control de acceso (ACL). Un atacante podría obtener información confidencial o la escalada de privilegios. Se ha reservado el identificador CVE-2019-19104 para esta vulnerabilidad.
  • La aplicación no emplea reglas adecuadas de control de acceso (ACL). Un atacante podría obtener información o modificar las configuraciones del sistema. Se ha reservado el identificador CVE-2019-19106 para esta vulnerabilidad.
  • Un atacante que explotara con éxito la vulnerabilidad en una de las funciones de la Base 800xA del Sistema ABB podría realizar una escalada de privilegios, ejecutar un código arbitrario y afectar a varias funciones de ingeniería, lo que conduciría a aplicaciones corruptas. Se ha asignado el identificador CVE-2020-8473 para esta vulnerabilidad.

Al resto de las vulnerabilidades se les han asignado los identificadores: CVE-2019-19105, CVE-2019-19107 y CVE-2020-8472.

Encuesta valoración