Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en OSIsoft PI Web API

Múltiples vulnerabilidades en OSIsoft PI Web API

Fecha de publicación: 
14/08/2019
Importancia: 
4 - Alta
Recursos afectados: 

OSIsoft PI Web API, versión 2018 y anteriores.

Descripción: 

OSIsoft ha detectado dos vulnerabilidades de inclusión de información sensible en archivos de log y de fallo de mecanismo de protección contra ataques CSRF.

Solución: 

OSIsoft recomienda a los usuarios actualizar a la versión PI Web API 2018 SP1 o posterior para corregir estas vulnerabilidades.

Detalle: 
  • Los ficheros de log creados por la aplicación OSIsoft PI Web, ante ciertos eventos, exponen información sensible, que puede ser aprovechada por un atacante para realizar ataques más sofisticados. Se ha reservado el identificador CVE-2019-13515 para esta vulnerabilidad.
  • Los mecanismos de protección contra ataques de tipo CSRF (Cross-Site Request Forgery) implementados en la aplicación no son efectivos en la versión vulnerable. Se ha reservado el identificador CVE-2019-13516 para esta vulnerabilidad.

Encuesta valoración