Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en MicroSCADA Pro SYS600

Múltiples vulnerabilidades en MicroSCADA Pro SYS600

Fecha de publicación: 
23/07/2018
Importancia: 
5 - Crítica
Recursos afectados: 

MicroSCADA Pro SYS600 9.2, 9.3, 9.4

Descripción: 

El investigador Vladimir Dashchenko de Kaspersky Labs ha reportado esta vulnerabilidad en las versiones del producto indicado anteriormente. Un atacante autenticado podría explotar esta vulnerabilidad lo cual provocaría un bloqueo remoto del proceso o la ejecución de código arbitrario en el sistema afectado.

Además, Microsoft ha documentado un problema conocido (bucle de reinicio), con los controladores antiguos Sentinel HASP, al implementar actualizaciones de seguridad de Microsoft en marzo de 2018 y siguientes. ABB ha confirmado los problemas de reinicio de bucle con al menos los sistemas Windows 7 y Windows Server 2008 SP2. Se recomienda seguir las instrucciones de este aviso para instalar la versión Sentinel HASP / LDK 7.80 con los controladores más recientes antes de implementar las actualizaciones de seguridad de Microsoft.

Solución: 

El problema se soluciona por Gemalto en la siguiente versión del producto:

  • Versión  7.80 de Sentinel HASP/LDK License Manager

ABB recomienda a los usuarios afectados aplicar esta actualización lo antes posible.

La actualización es soportada en los siguientes sistemas operativos: Windows 7 SP1, Windows 8.1 SP1, Windows Server 2008 R2 SP1, Windows Server 2012 R2, Windows Server 2016, Windows 10 Version 1709. Antiguas versiones del sistema operativo probablemente son también completamente compatibles, pero Gemalto no lo garantiza. Fuera de los sistemas operativos mencionados anteriormente, ABB ha probado la actualización en Windows Server 2008 SP2.

Detalle: 

Ejecución remota de código arbitrario: Un atacante podría explotar la vulnerabilidad existente en el servicio Sentinel HASP Run‐time Environment de forma remota, subiendo un fichero especialmente creado al mismo provocando un desbordamiento de búfer que permitiría ejecutar código arbitrario o apagar el proceso remoto (una denegación de servicio). Se han asignado los identificadores CVE-2017-11498, CVE-2017-11497, CVE-2017-11496, CVE-2017-12818, CVE-2017-12819, CVE-2017-12820, CVE-2017-12821, CVE-2017-12822 para esta vulnerabilidad.

Encuesta valoración