Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en dispositivos de Rockwell Automation

Múltiples vulnerabilidades en dispositivos de Rockwell Automation

Fecha de publicación: 
28/10/2022
Identificador: 
INCIBE-2022-0993
Importancia: 
4 - Alta
Recursos afectados: 
  • Software Cisco IOS XE y Cisco IOS incluido en:
    • Stratix 5800 switches, todas las versiones anteriores a v16.12.01.
    • Stratix 5400/5410 switches, todas las versiones anteriores a v15.2(7)E2 (solo CVE-2020-3200).
  • FactoryTalk Alarm y Events Server, todas las versiones.
Descripción: 

La explotación exitosa de estas vulnerabilidades podría ocasionar una condición de denegación de servicio (DoS) y permitir la ejecución remota de código. 

Solución: 
  • Stratix 5800 switches (todas las vulnerabilidades excepto CVE-2020-3200), actualizar a v17.04.01 o posterior .
  • Stratix 5800 switches (CVE-2020-3200), actualizar a v16.12.01 o posterior.
  • Stratix 5400/5410 switches (únicamente CVE-2020-3200), actualizar a v15.2(7)E2 o posterior.
  • Para FactoryTalk Alarm y Events Server, Rockwell Automation recomienda a los usuarios del software afectado que configuren IPsec para mitigar este problema, como se detalla en el artículo de la base de conocimiento 'Implementación del software FactoryTalk con IPsec'. Los clientes también están dirigidos a las estrategias generales de mitigación de riesgos proporcionadas en el artículo de la base de conocimiento de 'Pautas de seguridad recomendadas'.
Detalle: 
  • Un atacante no autenticado con acceso de red al servicio de alarmas y eventos FactoryTalk de Rockwell Automation de una víctima podría abrir una conexión, lo que provocaría un fallo en el servicio originando una denegación de servicio (DoS). El puerto afectado podría usarse como un puerto de ping del servidor y usa mensajes estructurados con XML. Se ha asignado el identificador CVE-2022-38744 a esta vulnerabilidad.
  • La interfaz gráfica de usuario (GUI) del administrador carece de una gestión correcta de RBAC, lo que puede permitir que un usuario malintencionado envíe solicitudes HTTP modificadas al dispositivo de destino. Si se explota, un atacante remoto de solo lectura podría ejecutar comandos o cambios de configuración como administrador. Se ha asignado el identificador CVE-2020-3229 a esta vulnerabilidad.
  • Una validación insuficiente de la entrada del usuario podría permitir que un usuario malintencionado inyecte una entrada personalizada en la interfaz de usuario web. Si se explota, un atacante remoto podría ejecutar código arbitrario con privilegios administrativos en el sistema operativo. Se ha asignado el identificador CVE-2020-3219 a esta vulnerabilidad.
  • Una vulnerabilidad en la funcionalidad de puerta de enlace de capa de aplicación (ALG) de DNS utilizada por la traducción de direcciones de red (NAT) en el software Cisco IOS XE podría permitir que un atacante remoto no autenticado reiniciara un dispositivo afectado. Se ha asignado el identificador CVE-2021-1446 a esta vulnerabilidad.
  • Una vulnerabilidad en el código del servidor Secure Shell (SSH) del software Cisco IOS y el software Cisco IOS XE podría permitir que un atacante remoto autenticado reinicie un dispositivo afectado. Se ha asignado el identificador CVE-2020-3200 a esta vulnerabilidad.
  • Una sanitización de entrada incorrecta, podría permitir que un usuario malintencionado con privilegios administrativos envíe una entrada especialmente diseñada en la interfaz de usuario web. Si se explota, un atacante remoto podría ejecutar comandos arbitrarios con privilegios de root en el sistema operativo. Se ha asignado el identificador CVE-2020-3211 a esta vulnerabilidad.
  • Una validación incorrecta de la entrada proporcionada por el usuario podría permitir a usuario malintencionado crear un archivo en el dispositivo de destino y cargar un segundo archivo malintencionado en el dispositivo, pudiendo ejecutar código arbitrario con privilegios de root en el shell subyacente de Linux. Se ha asignado el identificador CVE-2020-3218 a esta vulnerabilidad.

Para el resto de vulnerabilidades se han asignado los siguientes identificadores: CVE-2020-3209, CVE-2021-1385 y CVE-2020-3516.

Encuesta valoración