Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en CX-One de Omron

Múltiples vulnerabilidades en CX-One de Omron

Fecha de publicación: 
05/12/2018
Importancia: 
3 - Media
Recursos afectados: 
  • CX-One, versiones 4.42 y anteriores, incluyendo las siguientes aplicaciones:
    • CX-Programmer, versiones 9.66 y anteriores.
    • CX-Server, versiones 5.0.23 y anteriores.
Descripción: 

El investigador Esteban Ruiz de Source Incite, trabajando con Zero Day Initiative de Trend Micro, ha identificado varias vulnerabilidades de desbordamiento de búfer y de uso de memoria previamente liberada en productos CX-One de Omron. La explotación exitosa de estas vulnerabilidades podría permitir a un atacante ejecutar código bajo los privilegios de la aplicación.

Solución: 

Omron ha publicado nuevas versiones que solucionan estas vulnerabilidades:

  • CX-Programmer, versión 9.70
  • Módulo común, incluyendo CX-Server, versión 5.0.24
Detalle: 
  • Un potencial atacante podría utilizar un fichero de proyecto especialmente manipulado para sobrepasar el tamaño del búfer y conseguir la ejecución de código bajo los privilegios de la aplicación, provocando un desbordamiento de búfer basado en pila (stack based buffer overflow). Se ha asignado el identificador CVE-2018-18993 para esta vulnerabilidad.
  • Mediante la utilización de un fichero específicamente modificado, un potencial atacante podría explotar y ejecutar código bajo los privilegios de la aplicación, aprovechando un fallo en la comprobación de las referencias a memoria liberada. Se ha asignado el identificador CVE-2018-18989 para esta vulnerabilidad.

Encuesta valoración