Inicio / Alerta Temprana / Avisos Sci / Múltiples vulnerabilidades en ARC Informatique PcVue

Múltiples vulnerabilidades en ARC Informatique PcVue

Fecha de publicación: 
13/10/2020
Importancia: 
5 - Crítica
Recursos afectados: 

ARC Informatique PcVue, versiones desde 8.10 hasta la anterior a 12.0.17.

Descripción: 

Sergey Temnikov y Andrey Muravitsky, investigadores de Kaspersky ICS CERT, han descubierto 3 vulnerabilidades, 1 con severidad crítica y 2 altas, de tipo ejecución remota de código, denegación de servicio y exposición de información, que afectan a ARC Informatique PcVue.

Solución: 

[Actualización 08/01/2021]:

  • Para las versiones 12 (12.0.17 Maintenance Release) y 11.2 (11.2.06097 Update), actualizar PcVue a la versión v12.0.17.

El fabricante recomienda las siguientes medidas de mitigación:

  • Desinstalar la web y el backend móvil. Los usuarios que no utilicen los componentes afectados deben desinstalarlos. Si los componentes no son necesarios, no los instale.    
  • Endurezca la configuración del firewall asegurándose de que las conexiones entrantes en el puerto correspondiente estén autorizadas sólo si se inician con el proceso del servidor web de IIS. El puerto de escucha es configurable (por defecto 8090) y puede haber sido cambiado en el sistema usando el Explorador de Aplicaciones.

El proveedor proporciona más información para solucionar estas vulnerabilidades en el boletín de seguridad SB2020-1 (se requiere inicio de sesión) disponible en el listado de Alertas de Seguridad de PcVue.

Detalle: 
  • Debido a la deserialización insegura de los mensajes recibidos en la interfaz, se puede realizar una ejecución de código arbitrario (RCE) en el servidor backend de Web & Mobile. Se ha asignado el identificador CVE-2020-26867 para esta vulnerabilidad.
  • Debido a la capacidad de un usuario no autorizado de modificar la información utilizada para validar los mensajes enviados por clientes web legítimos, una vulnerabilidad de denegación de servicio (DoS) podría evitar que los usuarios legítimos se conecten y operen correctamente con WebVue, WebScheduler o la aplicación móvil TouchVue. Se ha asignado el identificador CVE-2020-26868 para esta vulnerabilidad.
  • Una vulnerabilidad de exposición de información podría permitir a un usuario no autorizado acceder a los datos de sesión de usuarios legítimos a través de WebVue, WebScheduler o la aplicación móvil TouchVue. Se ha asignado el identificador CVE-2020-26869 para esta vulnerabilidad.

Encuesta valoración