Inicio / Alerta Temprana / Avisos Sci / Ejecución remota de código en OPC Labs QuickOPC

Ejecución remota de código en OPC Labs QuickOPC

Fecha de publicación: 
29/07/2022
Identificador: 
INCIBE-2022-0856
Importancia: 
4 - Alta
Recursos afectados: 

Connectivity Explorer (parte de QuickOPC), versiones anteriores a 5.63.246 (QuickOPC 2022.1 build 246).

Descripción: 

Steven Seeley (mr_me), investigador de Source Incite, en colaboración con ZDI de Trend Micro, ha reportado una vulnerabilidad de severidad alta que podría permitir a un atacante remoto ejecutar código arbitrario en OPC Labs QuickOPC.

Solución: 

Actualizar Connectivity Explorer a las versiones 5.63.246 o posteriores, que ya restringen los tipos que se pueden cargar.

Detalle: 

Connectivity Explorer permite al usuario guardar y cargar archivos XML con la lista de "Live Points". Al abrir el archivo, Connectivity Explorer no lo gestiona como datos no confiables, lo que podría permitir a un atacante elaborar un archivo especialmente diseñado para ejecutar comandos en el ordenador del usuario. Se ha asignado el identificador CVE-2022-2561 para esta vulnerabilidad.

Encuesta valoración