Inicio / Alerta Temprana / Avisos Sci / Desbordamiento de búfer en enteliBUS Controllers de Delta Controls

Desbordamiento de búfer en enteliBUS Controllers de Delta Controls

Fecha de publicación: 
28/08/2019
Importancia: 
5 - Crítica
Recursos afectados: 
  • enteliBUS Manager versiones de firmware 3.40 R5 build 571848 y anteriores;
  • enteliBUS Manager Touch (eBMGR-TCH) versiones de firmware 3.40 R5 build 571848 y anteriores;
  • enteliBUS Controller (eBCON) versiones de firmware 3.40 R5 build 571848 y anteriores.
Descripción: 

Los investigadores, Douglas McKee y Mark Bereza, de McAfee Advanced Threat Research, han reportado una vulnerabilidad del tipo desbordamiento de búfer que afecta a equipamiento enteliBUS Controllers de Delta Controls. Un atacante, en la misma red, podría conseguir acceso completo al dispositivo y ejecutar código con privilegios de administrador.

Solución: 

Delta Controls ha publicado la actualización enteliBUS 3.40 R6 build 612850. Este nuevo firmware es únicamente accesible para partners registrados. Para poder obtener la actualización se recomienda contactar con Delta Controls o un distribuidor.

Detalle: 

La vulnerabilidad de desbordamiento de búfer se debe a la falta de validación de la entrada. Un atacante remoto podría ejecutar código arbitrario. Se ha asignado el identificador CVE-2019-9569 para esta vulnerabilidad.

Encuesta valoración