Inicio / Alerta Temprana / Avisos Sci / Desbordamiento de búfer basado en pila en H0-ECOM100 de Host Engineering

Desbordamiento de búfer basado en pila en H0-ECOM100 de Host Engineering

Fecha de publicación: 
21/09/2022
Identificador: 
INCIBE-2022-0930
Importancia: 
3 - Media
Recursos afectados: 

H0-ECOM100 con versiones de firmware 5.0.155 y anteriores.

Descripción: 

David Formby y Caleb Purcell de Fortiphyd Logic han informado de esta vulnerabilidad a CISA. El módulo de comunicaciones H0-ECOM100 contiene una vulnerabilidad de desbordamiento de búfer basado en pila.

Solución: 

Actualizar el firmware en el H0-ECOM100 a la versión v5.0.156 o posterior, usando la utilidad de programa gratuita llamada NetEdit3, descargable desde el sitio web de Host Engineering.

Detalle: 

Un atacante podría, mediante un código personalizado, escribir más caracteres de los permitidos en los campos de nombre o descripción provocando un desbordamiento de búfer basado en pila, causando que el dispositivo afectado se bloquee. Se ha asignado el identificador CVE-2022-3228 para esta vulnerabilidad.

Encuesta valoración